Author [ES] [CA] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: Heated grip not working  (Read 887 times)

0 Members and 1 Guest are viewing this topic.

Offline mym

  • Tiger Member
  • **
  • Posts: 26
  • Bike: Tiger 800 XR
  • Location: North East
Heated grip not working
« on: November 28, 2019, 06:36:04 PM »
As is typical when it's gets cold, one of the oe heated grips on my 2015 xr has stopped working.

It got luke warm this morning and stayed cold on the way home tonight.

It's the left grip that's stopped working, the right one is working perfectly at the mo.

Is there anything worth checking, or is this just a replacement job?

Thanks

Offline tauzero

  • Tiger Master
  • ****
  • Posts: 793
  • Bike: Tiger 800 XRx
  • Location: Tamworth, UK
Re: Heated grip not working
« Reply #1 on: November 28, 2019, 10:31:10 PM »
Might be worth checking the connector to the grip. https://www.triumphinstructions.com/ProdDocs/A9638170-EN.pdf shows how they're fitted.
Tiger 800 XRx, Bonneville T120 Black, SpeedTona, Speed Dent
Gone but not forgotten: Scrambler 900, Tiger 1050, Bonneville SE, Sprint ST 955i, Trophy 4, Sprint 900, Daytona 900, Tiger 900, Trident 900

Offline GlasgowTiger

  • Tiger Cub
  • *
  • Posts: 8
  • Bike: Tiger XRX '15
  • Location: Glasgow
Re: Heated grip not working
« Reply #2 on: March 03, 2021, 12:42:17 PM »
 :460:
*Originally Posted by tauzero [+]
Might be worth checking the connector to the grip. https://www.triumphinstructions.com/ProdDocs/A9638170-EN.pdf shows how they're fitted.

Thanks for the fitting instructions, very useful 👍 First time taking my grips off of my tiger and I pulled thinking it was just friction causing slight resistance and I've pulled the connectors out. I was worried I was somehow meant to connect them together from inside the bar via the small access hole, hopefully I'll be successful when I go fishing to bring the connector out the end of the bar.. first, lunch! Thanks again!

 


Recent Topics