Tiger 800 / 900 - Main Discussion Section > Brakes and ABS

TC & ABS warning lights on my 900 GT

(1/2) > >>

YorkieBoy:
Returned last night from a great 350 mile back road ride around to my brother's in Pickering on my fairly new (4500 miles) 900 GT. 20 miles from home I seized a passing opportunity and gave it the biggest beans it had had all day. I was presented with a technicolour display telling me the Traction Control and ABS had failed. I tried locking the back wheel but that rear brake...no ABS rattles anyway. I stopped, switched off & on and it appeared to clear the system. The warning lights have not returned (yet) but I guess a visit to the dealers is in order.

Anyone else experienced this? Apologies if I've missed the answer.

Stevie.P:
1. Check for fault codes with diagnostic software, I.e Tigertool or I think there is a routine for displaying the fault codes, possibly in 900 handbook, definitely can on the 800 though not in the handbook, or search recent forum threads.

2. Check battery charging voltage, but really needs to be checked if fault lights reappear and, on the 800, that's a pain if the bike needs switching off the remove seat for access. The reason I mention this is I had months of occasiinal similar fault lights before they finally came on permanent and I had around 19v charging at idle and it was the regulator/rectifier finally giving up.

https://www.tiger800.co.uk/index.php/topic,24031.0.html

chuckxc:
That's exactly what will happen if it is still in Off Road or Off Road Pro Mode.
Turning off and on again the ignition will automatically revert to Road Mode, and no warnings.

YorkieBoy:
Both responses are much appreciated. The bike's only a year old and has been regularly used so I don't think it's the battery or rectifier - but I will check this. It wasn't in Off-Road Mode but the symptoms do bear this out. In my excitement of releasing the horses, how unlikely is it that I accidentally knocked it into Off-Road?

TIger Lad:
Nothing like that happened to my gt pro, only hiccup I have had was today when I had to brake very hard, closed throttle, clutch in and the engine suddenly stopped no warning just stopped.  Out again tomorrow try repeat what you did see what happens.

Navigation

[0] Message Index

[#] Next page

Go to full version