Author [NL] [FR] [ES] [DE] [SE] [IT] Topic: Tiger 900 - Engine Management Light Question  (Read 771 times)

0 Members and 1 Guest are viewing this topic.

  • Offline mjab   gb

    • Tiger Pro  ‐    174
    • ***
    • Topic Author

    Offline mjab

    • Tiger Pro
    • ***
    • Topic Author
    • Posts: 174
    • 4 wheels move the body, 2 wheels move the soul
    • Bike/Model: Tiger 900 GT Pro
    • Location: Waterlooville
    • Country: gb
    Tiger 900 - Engine Management Light Question
    on: Nov 04, 2021, 08.46 pm
    Nov 04, 2021, 08.46 pm
    Last weekend I had to attempt to connect some cables to the battery terminals.
    Being my usual clumsy self I managed to drop one of the screws and it rolled into the battery tray and now hiding.
    Found another and reconnected and now have the service (EML) light on

    Now on my Explorer any issues with battery disconnection or a flat would give me the service light for 3 starts up to temp then clear. Does anyone know if this is the same for the 900 as now done 4 starts and still have the light on?

  • Offline Worty28

    • Tiger Member  ‐    32
    • **
      #1

    Offline Worty28

    • Tiger Member
    • **
    • Posts: 32
    • Bike/Model: Tiger 900 GT LRH
    • Location: Ontario, Canada
    Re: Tiger 900 - Engine Management Light Question
    Reply #1 on: Nov 05, 2021, 09.49 am
    Nov 05, 2021, 09.49 am
    I've disconnected my battery many times and have never had the service light come on.   I would scan it and see what the code is.  TigerTool works great now on the 900.

  • Offline rp8283

    • Tiger Cub  ‐    2
    • *
      #2

    Offline rp8283

    • Tiger Cub
    • *
    • Posts: 2
    • Bike/Model: 800xca
    • Location: Highlands GB
    Re: Tiger 900 - Engine Management Light Question
    Reply #2 on: Nov 05, 2021, 05.39 pm
    Nov 05, 2021, 05.39 pm
    Forgive me if I appear to be mixing up things here - but are you talking about the Engine Management Light  or the  service light spanner) that tells you that it needs a service? ... On new to me XCA when I disconnected the battery the service light came on as clock/date reset it self.  Updated the time and date and everything was ok (light went out).. Cheers

  • Offline mjab   gb

    • Tiger Pro  ‐    174
    • ***
    • Topic Author
    • #3

    Offline mjab

    • Tiger Pro
    • ***
    • Topic Author
    • Posts: 174
    • 4 wheels move the body, 2 wheels move the soul
    • Bike/Model: Tiger 900 GT Pro
    • Location: Waterlooville
    • Country: gb
    Re: Tiger 900 - Engine Management Light Question
    Reply #3 on: Nov 05, 2021, 08.47 pm
    Nov 05, 2021, 08.47 pm
    *Originally Posted by rp8283 [+]
    Forgive me if I appear to be mixing up things here - but are you talking about the Engine Management Light  or the  service light spanner) that tells you that it needs a service? ... On new to me XCA when I disconnected the battery the service light came on as clock/date reset it self.  Updated the time and date and everything was ok (light went out).. Cheers

    Only done 200 miles so 1st service is still 400 miles away. Maybe it is for that. All I know is when I put the fog lights on the yellow warning moves from the left of the screen to the right   :187: :187: :187:

  • Offline mali_veseljak

    • Tiger Cub  ‐    3
    • *
      #4

    Offline mali_veseljak

    • Tiger Cub
    • *
    • Posts: 3
    • Bike/Model: Tiger 800 xrt
    • Location: Bosnia and Herz
    Re: Tiger 900 - Engine Management Light Question
    Reply #4 on: Dec 02, 2021, 11.32 am
    Dec 02, 2021, 11.32 am
    Did you check date and set correctly? If you disconnected battery, date will be reset. So maybe light is for service because the computer thinks it's been over a year from last one.

     


    winded-staunch